Elastic Search

TransAmDan

Forum Admin
Staff member
The search feature on this forum could be better. Has anyone tried the search feature? It does work but apparently could be better.

An enhanced version of the XenForo search system, allowing higher quality results and faster searching for bigger installations. Requires Elasticsearch 2.0 or newer and is generally only appropriate for customers running a dedicated server or VPS. (details)
We have a dedicated server which is the next level up from VPS meaning I have total control over the server. It's running CentOS6 which is getting a bit old now, but should be fine.
To install Elasticsearch I need certain utils in Linux, may need to upgrade PHP.

There are verious install guides and they all seem soo different. Different install methods in Linux.
https://tecadmin.net/install-elasticsearch-on-linux/
 

TransAmDan

Forum Admin
Staff member
This has now been installed.

Previously if i searched for 'Southsea Cruise' in the Albums I got one result. I now get many. This search is far superior to the default search. So should be very useful for searching the forums. Give it a shot ;)
 

TransAmDan

Forum Admin
Staff member
Great just what I needed. Xenforo thought Elastiserach is present(disabled now), but its not installed on this server yet. I will do this later. Trying to find what install guide I used. Found it in this thread. Very useful. Glad I posted now.

This enhances the search, so we can still search without it.
 

TransAmDan

Forum Admin
Staff member
Got it done, that was a nice simple install had to install a few others things first for the install to work. :)
 

TransAmDan

Forum Admin
Staff member
It appears the search feature isn't working correctly.

May be a trip into the operating system to kick start it. I'll try to get this done today. only noticed it when trying to search Albums for a show, and there was no results. Looking in the control panel it dosn't appear to be indexing pages.
 

TransAmDan

Forum Admin
Staff member
Fixed. It was actually a much bigger issue.

The server has a 120GB hard drive, it got fulled up with log files etc. Due to little space the Search wouldn't work, along with emails giving issues logging into the server. It was a bit of a mess.

Cleared some space, now 32Gb saved, its running sweet again.
 
Top